Troubleshooting: Slow Outlook

Problem

Outlook is very slow to load content, create folders and populate calendar items.

Cause

If you're not using cached Exchange mode your Outlook has to load all emails and calendar items each time you open it. Further, it is constantly searching for changes on the Exchange server and this will slow it's performance. 

Solution

Confirm or modify Outlook's Cached Exchange mode:

  • Open the Outlook desktop application
  • Click on file
  • Choose your account
  • Click on Account Settings to open the Account Settings page

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  • Select your account
  • Click Change
  • Make sure to check "use cached Exchange Mode" and limit cached time. Longer times mean more emails to download and a slower Outlook.

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I'm already using cached Exchange mode

If you're already using cached exchange mode you may benefit from clearing the cached resources and turning it back on. To do this disable cached exchange mode, restart Outlook and turn cached Exchange mode back on.

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Details

Article ID: 7766
Created
Wed 11/29/23 11:20 AM
Modified
Wed 11/29/23 11:46 AM